Shoud've bought the 3.0 though. Or even the 2.2.