First off, the PO had wired in a relay to the headlight position switch which in effect changed the function so that the sidelights didn’t come on when the ignition was off. Presumably so you can have the headlights up and the rest of the car off. Fair enough, but it dangles around and hits my knees so that came out.

Second, we discovered that the positive for the dip beam had burnt out previously. No wonder seeing as it’s not relayed at all and the direct power goes through both the headlight switch on the stalk and the position switch. The PO had replaced that with various relays tapped off various wires so that the lights came on with the position switch. Again, fair enough, but we’ll redo it as some of the wire gauges are teeny-tiny for the load they’ll be carrying.

Lastly, we discovered that this relay assortment had been spliced into two relays in the fusebox which don’t appear on any of the wiring diagrams we can find...but are in a photo in the Haynes manual. What the what?! Oh, and half of the wires running to/from this relay appear to have melted. One of these goes to the fog lamp switch. The second output is plugged directly into the trigger feed so once activated it triggers itself. The next one shares a couple of wires (hopefully earths) and seems to go to the wiper switch.

These three revelations took all day to discover. Why? This is why:

Why so many wires? There’s only a dozen or so electrical systems in the whole car. Why the world’s supply of wiring? At least they’ve got a good array of colours so it’s not a monotone nightmare to trace.

Advertisement

Oh, and if anyone wants to see a narrowly avoided vehicle fire, this is what one looks like:

Advertisement

Melted insulation all up the length of wire to the fog lamp switch which runs through big looms and adjacent to carpet. Also melted insulation on that weird triggers-itself-positive-feed. Current thinking is that the fog lamp system doesn’t have a fuse as standard and there’s a short somewhere further down the line. We’ll see tomorrow I suppose!

Oh, and also nearly managed to brick an £100 fusebox when we went to disconnect the main power in and the spade terminal came out with it! Pulled out of the circuit board within the sealed-ish box. Luckily we were able to carefully pry it open and solder it back on, but that was a tense half-hour or so :S

Isn’t wiring fun? ;)