This is a platform for User Generated Content. G/O Media assumes no liability for content posted by Kinja users to this platform.

Jolene is having some work done today, by someone other than my friend and I - for the first time.

Just dropped Jolene off at a local shop to have her MAP and O2 sensors replaced. I have an intermittent “check engine” light as well as a rough/low/lopey idle and an occasional stalling problem. I also have hard starts sometimes and low gas mileage (low-20s).

We scanned the code early last winter and it was a Code 13. “Oxygen sensor circuit open or no activity.”

Advertisement

It’s been this way since I got the car, with the exception of the light. That didn’t start until last autumn in a Target parking lot. I always just assumed an old J-body was supposed to run rough, and I’m sure it will - to a certain extent. But, the car has basically been in a perpetual state of confusion with these sensors being iffy for two years now (I bought the car August 4, 2018).

I think this work will have her in tip-top shape. I’d normally take her to my mechanic friend, but he is busy remodeling a house and couldn’t get to it for a month or more. My OCD/impatient ass found a local trustworthy shop, so that’s where she is today.

Advertisement
Illustration for article titled Jolene is having some work done today, by someone other than my friend and I - for the first time.
Photo: Mazda616
Illustration for article titled Jolene is having some work done today, by someone other than my friend and I - for the first time.
Photo: Mazda616
Advertisement
Illustration for article titled Jolene is having some work done today, by someone other than my friend and I - for the first time.
Photo: Mazda616

Share This Story

Get our newsletter