What is the sound of one piston slapping?
What is the sound of one piston slapping?
Illustration for article titled Mini Update: Dead

So after rebuilding the head, turbo, etc, what’s wrong? No rail pressure above 90psi on startup then after a few starts it rises up to 1k and will cut back to 90psi on hard acceleration, Now with heavy misfires.

Advertisement

After replacing the hpfp and in tank pump to no avail, I was driving it to work trying to better understand the problem and its conditions. Under acceleration from a turn it started cutting fuel then stuttered heavily and began misfiring. Kept misfiring with codes for all cylinders, barely got it home.

Illustration for article titled Mini Update: Dead
Advertisement

Tried a new coil because it seemed to level out onto 1 cylinder to no avail, tried a used fuel rail with injectors and sensor to cross those off the list, Nope. It seems be okay around 2-3k with no load but at idle it can barely keep itself alive(other times it idles fine). When under load misfires occur, even with proper fuel pressure. The plugs are new, coils all working.

Did a compression test, my ebay gauge always seems to read very low so I got 100psi across all cylinders which would indicate none of them are particularly down (on a different engine it wouldnt go above about 100psi, but the down cylinders still showed 70 or whatever amount less).

Advertisement
Illustration for article titled Mini Update: Dead

Whats left is potentially the internal relay within the fuse panel that controls fuel systems, perhaps it is not allowing enough amps? Not sure how it would maintain fuel pressure while missing so heavily though.

Advertisement

At this point I’ve given up, the car is going to get parked. The last bit of money it will see is perhaps a car cover to hold it over until the payments are done.

TL/DR: I don’t have the skill or knowledge to diagnose the problem, it is either internal engine damages or electrical. Either way I’m over it for now.

Share This Story

Get our newsletter