Reddit’s Just Rolled into the Shop is a veritable cornucopia of the many wonders and oddities of shop lyfe. You never know what’s gonna roll in. Here’s what caught my eye this week.


Photo: fullock

Lotus steering crack


Photo: alamoheart

Advertisement

That’s barely dairy, Harry...


Photo: Hi-Scan-Pro

3.3 in a ~14MY Kia Sorento

Advertisement


Photo: DiarrheaInTheShower

Bet it’s a qualiyt part, guarantede to last too.

Advertisement


Photo: TCSnarFF

Who needs oil anyway?

Advertisement


Screenshot: bigcockjake

(click for video)

Advertisement


Photo: collegefurtrader

NSFW

Advertisement


Photo: collegefurtrader

(Transmission cooler lines)

Advertisement


Photo: WELincolnSF

2010 Lincoln MKT 3.5 ecoboost.

Advertisement


Caliber... Customer concern: Small squeaking noise while turning. Test drive lasted once I touched the brakes and immediately took the car into the shop. Driving at 5 mphs was frightening, I can’t even imagine how this thing was on the highway.

Advertisement


Photo: projectd88

Advertisement

Where can I find a socket for my impact that will fit this thing?


Photo: TheBradbarian

Advertisement

Holes-Royce


Photo: thefallingpebble

Advertisement

What kind of spider is that?


Photo: flaccomcorangy

Advertisement

“Not my problem” -Ford


Photo: SkipyB

Advertisement

Aw, boo hoo. You better hope I don’t ALSO have to adjust the mirrors, for a safe test drive.


Photo: Marcusskz

Advertisement

Fun fact: RockAuto’s MOST expensive front bearing for a 2WD Expedition like this is about ten bucks. Could have done both front inners & outers, plus grease seals and spent about $60 (or less) in parts. Too late for that now...


Photo: iRagedaily

One of my straps broke.

Advertisement


Photo: lol_the_fbi

One of the worst I’ve ever seen!

Advertisement


Photo: bigocrews

Soon be found on Craigslist, listed among the car’s “performance mods”.

Advertisement


Photo: Terabyte47

Car came in on a flatbed. Says he tried replacing the spark plugs to fix a misfire... A helicoil was installed but still didn’t run right. No compression. Finally took the head off and found both of those valves chipped. Were they chipped before or after he fucked up the threads, we have no idea. Found the cylinder walls also damaged...

Advertisement


Photo: ppadge

Advertisement

STAHP IT


Photo: nacnud99

Advertisement

Obligatory brake post


Photo: Captian_Dan

Advertisement

Obligatory tire post