Not SE though, that needs Windows 95.

Advertisement

Share This Story

Get our newsletter