Need some advice regarding the SAI system on my Disco II (2003). Ole Jazzie is throwing P1412 and P1415 showing fault on the SAI both banks. I inspect and investigate and see that the high-temp hoses connected to the (I have no fucking clue what these things are called) are cracked and definitely need replacement. Hopefully my super large images don’t break the kinja.......

This:

Goes into one of these on each side of the motor:

In order to remove these hoses so I can get replacement parts I need to pull off the entire SAI system. (Don’t worry Jazzie is not being driven right now - no tags because no pass inspection)

Advertisement

Rigid SAI/EGR tubing that the rubber hoses were clamped onto, that then go into the weird silver things on each side.

Advertisement

Advertisement

Advertisement

This leads me to the next couple of bits: I removed the rigid recirculation tubing and then began removing the actual SAI pump. I had been told on the forums that when the SAI pum pis going out is will sound like a jet engine on cold start. I have not yet experienced this issue, but have heard of the sometimes necessary rebuild of the SAI pump. Well I opened the end piece to see what was what. In the below pictures you should see the inside. I have no idea what this is actually supposed to look like as I have never removed or seen one of these opened before.

Advertisement

Advertisement

The empty hole where the SAI pump/solenoid/filter/thing????? goes:

Advertisement

Annoyingly, this system (from my limited research) only exists to make it California emissions legal. I live in TN and wish it could be as easy as removing it and going to the inspection station, but I’m going to go out on a limb here and say that this cannot be done for reasons. But I cannot deny my secret desire to crank her up and run her down the street with no intake or SAI system on. Also, so much more space in the engine bay with it gone, for activities.