“It’ll take like... seconds.” I said. “It’s just four bolts!” I said. “How hard could it be!?” I foolishly, foolishly said. To be fair I was correct in theory. In theory the carburetor goes together like a child’s puzzle and should have been do-able in under an hour. Weber/ Redline, however, intervened.

After the coolant fiasco, which I am still not convinced is over, given Weber expects a paper gasket to hold back coolant… but that is for another day, the carburetor was pretty much ready to bolt on.

So basically this whole tale is going to be a detail of how crappy the instructions that came with the carb are. They’re very generic, but with just enough specific information about the carb peppered in so that you think they might not be.

I started by installing the adapter plate and studs using removable threadlock, as suggested by the instructions. As per the instructions I also applied “a suitable gasket sealer (Silicone or RTV is NOT suitable”. Apparently they mean gasket dressing? Luckily I had some... so hopefully that is the right stuff.

Advertisement

After the thread lock set, it was a simple matter of matching the big hole in the carb with the big hole in the intake, slapping the gaskets in, and bolting down the carb.

Wait… but the directions say “Install the carburetor with gasket to the adaptor with the linkage towards the right (passenger side) fender.” That is like… the opposite of how I just did it.

Advertisement

Ok, remove the carb, gaskets, and spacer and try again.

Ok but now the holes are mismatched! I guess that is OK? I dunno. On the the fuel pickup is on the wrong side…. And the throttle cable has to basically go a full 360 around the carb and/ or make some really weird angles. Hmm no I don’t like that.

Ok, remove the carb, gaskets, and spacer and try again.

Ok but the gaskets are still kinda odd and I guess the spacer isn’t a 1:1 mate anyway… Maybe I’ll google it. Yeah looks like someone else has it the other way. Heh ok….

Advertisement

Ok, remove the carb, gaskets, and spacer and try again.

The next step goes on to say “slide the throttle cable bracket over the two adapter studs closest to the valve cover.” Ok but… that isn’t possible with the carb in this orientation. Even if the geometry of the carb would allow that, which it doesn’t, that would have the throttle cable _pushing_ the throttle linkage and I don’t think that is right.

Ok, remove the carb, gaskets, and spacer and try again.

Ugh wait now all the adjustments are on the back! That’s not going to work!

Ok, remove the carb, gaskets, and spacer and try again.

Advertisement

Ok so… now that we’re pretty sure the carb is in the right orientation, the one specified in the first place, and the throttle bracket in the right spot, opposite of what was indicated, let’s figure out the throttle linkage adapter, kit number 99007.116. Cool, it comes with its own instructions!

“Assemble as shown”

Uhh… but… there isn’t an assembled picture.

“Assemble as shown.”

But like… what are all these extra pieces for? What even is this?! Is there a missing page.

Advertisement

“Assemble as shown.”

:sigh: God damn it.

Ok so at this point the directions go in the bin and we’re going to go with what seems right.

Advertisement

What I came up with is wrong as I’m using the hole intended for the throttle cable to hold the return spring and I think what is supposed to be for the return spring for the throttle linkage. Ahh well. It lines up really well and seems sturdy, so I’m sending it. My last carb kit I ended up with bailing wire as my throttle linkage, so this is an improvement.

DAMN YOU AUTOFOCUS!

Advertisement

With that sorted, and dry fit, everything got bolted down for real. Vacuum lines were connected or plugged, as appropriate, and the fuel line was run. Suddenly, it was starting to look like I had a complete car!

I hooked up my eBay smoke injector thingy to check for leaks and, shockingly, didn’t find any!

The last little niggle was getting a connection for the automatic choke. The car came fitted with a manual choke, so it was a matter of finding a switched 12V source somewhere in the engine bay, or running one from the interior. The coil and ingnitor were good choices, but neither were spade or screw terminals, so we’d be looking at a cut-and-solder - not ideal. I poked around in the wiring diagrams for other options.... and found a connection labeled “automatic choke”.

Advertisement

“But wait!” I said. “This car had a manual choke.... didn’t it?” Checking the owner’s manual confirmed that no, it did not. The PO added a manual choke for... reasons. I guess that explains why it looked like a tacked on AutoZone special... because it was!

Alright, after a little bit of a fuss actually confirming which wire was for the automatic choke, information the I eventually found in the Haynes manual of all places, I got the choke connected.

Advertisement

For good measure I drained the gas tank (because this thing has a gas tank drain!!) and refilled with fresh gas.

So. Many. Spiders.

Not being able to think of any more excuses, it was time to try starting. With dry fuel lines, I didn’t bother trying to build oil pressure first, figuring they’d build simultaneously.

Advertisement

Key in... first test of the starter... it cranked! Sounded good too.

We alternated about 7 seconds of crank with about 10 seconds of rest. After burning out the starter in the Saab I don’t really wail on starters like I used to.

After about 20 seconds of cranking the oil light turned off.

Shortly thereafter fuel started flowing through the filter.

To shots of carb cleaner and....

Advertisement

Woo! The throttle cable was too tight, so it was idling around 2k RPM. We killed it adjusted the throttle cable, and against all odds it restarted without any fuss. Idle was now around 700 RPM, low but acceptable for now, and the engine was purring like a kitten. SUCCESS!

Honestly I’m shocked it went as smoothly as it did. Still a lot to work on, dress, and confirm, but a running engine is a phenomenal step.

I rewarded myself by finishing the air cleaner project. So happy with the results.

Advertisement

Sadly, I don’t think I’m going to have much time to work on it before we have to fly out for Thanksgiving, but I’m happy I can now say I am back to 100% running(ish) cars!

Advertisement

...as long as there are no followup questions.