Update on my WRX's noisy clutch:

VERIFIED VERY FAINT SQUEAKING NOISE - LUBRICATED CLUTCH PEDAL ASSEMBLY AND SLAVE CYLINDER/FORK CONTACT PIVOT POINT - NOISES SEEM TO HAVE GONE AWAY AT THIS TIME

Yeah, at that time, but I can hear the chirps clearly.

What they did manage to fix, which I didn't even complain about, was the noisy clutch pedal. It crunched some as I'd disengage the clutch. So, yay?

Advertisement

Both of the sounds in my original post were linked to a bad throwout bearing by the shop foreman.

I haven't investigated the first sound (cold start squeal) but I highly doubt the lube job did the trick. So, apparently the next step is to pull the transmission out and investigate further, which I really wish didn't have to happen.

The chirp does seem to have gotten a bit more faint while I'm driving, and it's not doing it at idle, but that particular sound always had a mind of its own. I've noticed it's more audible when I'm off throttle and the RPMs are dropping.

Who fucking knows? Cars are a pain in the butt, you guys.

I'm busy with work this week so I'm not so sure I'll have the time to drop it off for them until the following week. We'll see what happens. Hopefully this gets resolved without much hassle. Fortunately it is just obnoxious noise that I'm dealing with. It's nothing that seems to be hindering performance. And I've still got another 4 years of warranty before I should start stressing out about things.

Advertisement

I'll give them a call tomorrow and look at my options.

Share This Story