...by a client who doesn’t need it anymore for my HP Pavilion Touchsmart 14 running Linux Mint 18.3.

Clearly I am a wealthy and fashionable gentleman. :P